読者です 読者をやめる 読者になる 読者になる

getalog

console.log geta6

eslint-plugin-import@0.9.1で全ルールがデフォルトオフになった

.eslintrcでルールを指定していなかった場合、0.9へアップデートした途端に動かなくなる。

前のまま使い続ける場合、以下のような感じでルールをeslintrcへ追記する必要がある。

{
  "plugins": [
    "import"
  ],
  "settings": {
    "import/parser": "babel-eslint"
  },
  "rules": {
    "import/no-unresolved": 2,
    "import/named": 2,
    "import/namespace": 2,
    "import/default": 2,
    "import/export": 2
  }
}